TW200 Forum
Would you like to react to this message? Create an account in a few clicks or log in to continue.
TW200 Forum

Forum for all TW200 Owners/enthusiasts
 
HomeHome  SearchSearch  RegisterRegister  Log in  

 

 Nice Forum

Go down 
AuthorMessage
covrod



Posts : 3
Points : 0
Reputation : 0
Join date : 2008-12-29
Location : Pine, CO.

Nice Forum Empty
PostSubject: Nice Forum   Nice Forum Empty12/29/2008, 1:39 pm

Glad I found this forum. Bought a TW200 new in 1994 and still have it although I'm going to sell it. Just don't ride it much anymore so time to let someone else have some fun. Been a great bike and never let me down. If I don't sell it, my daughter is interested in starting to ride so she'll be on it next summer. Bike has sat in the garage for almost 10 years with less then a 100 on it each year. Not sure it is jetted correctly since I now live at 8400 feet. I pulled the jets and its hard to read but I think the main jet says 94? And the other one says 40. The bike is slow to come back down to idle. Not sure if that is a jetting issue or not. Just installed a new plug and pulled the carb and cleaned it although it was spotless inside.
Back to top Go down
 
Nice Forum
Back to top 
Page 1 of 1
 Similar topics
-
» Another 4x4 overland travel forum...........
» affordable rain barrel-FOUND!
» Forum RPG
» POLL: How did you find the SFG Forum?
» just found this forum...FANTASTIC!

Permissions in this forum:You cannot reply to topics in this forum
TW200 Forum :: General :: New Members-
Jump to: